• Advertisement
Help a good cause...like donating to AerioStyle.com!

Strange Aerio radiator problem behavior

Share your latest home-made autocross video or your latest track time.

Strange Aerio radiator problem behavior

Postby bestleads » Sun Sep 28, 2014 11:13 pm

My 2003 Aerio is taken careful care. It is treated like a family member.

I live in Puerto Rico, tropical, where we have a 12 month summer weather. No cold weather seasons.

Following the owner's manual instructions the coolant level at the water reservoir was constantly checked.

It had this problem: The water reservoir is filled up to the max line.
When driven it would over fill. And the radiator lost water.

After that I checked radiator and constantly added coolant.

the Radiator cap was changed.

Mechanic and radiator people said it was no problem.

Last week the rad exploted breaking the taps.

It was replaced with a new one with new hoses.

Air flow meter, crankshaft sensor were checked, mechanic said they are ok.

Water pump broke and was replaced with a new one.

Computer was replaced with a used one.

The older computer got wet from rain water from windshield filtering. This was fixed with urethane rubber and top had fixing, soldering and repainting job done on it.

The radiator has the same problem, reservoir keeps overflowing and coolant has to be added to the radiator.

No coolant is leaked to the floor.

Could it be the thermostat, or what? :thinking: ?
bestleads
Aerio Virgin
Aerio Virgin
 
Posts: 1
Joined: Sun Sep 28, 2014 10:43 pm

Advertisement

Help a good cause...like donating to AerioStyle.com!

Re: Strange Aerio radiator problem behavior

Postby Woodie » Thu Oct 02, 2014 4:41 am

Bad head gasket. Exhaust gasses are pressurizing the cooling system, pushing the coolant out. There's a test, some auto parts stores will loan out the tester, if not, they're not expensive,
I'll include a video, and then your post will suddenly be in the right place:

https://www.youtube.com/watch?v=Pp3FWH-YnHU
I will not run anyone's life - nor let anyone run mine. I will not rule nor be ruled. I will not be a master nor a slave. I will not sacrifice myself to anyone - nor sacrifice anyone to myself." - Ayn Rand
User avatar
Woodie
AerioStyle Addict!!!
AerioStyle Addict!!!
 
Posts: 1223
Joined: Sun May 07, 2006 7:25 pm
Location: Washington, DC

Re: Strange Aerio radiator problem behavior

Postby wildebeast » Fri Oct 03, 2014 1:07 am

The thermostat should have been changed a long time ago, before a lot of the other stuff you mentioned. it is inexpensive enogh & very easy to get to. Try it & see, it almost sounds as if it has passed that point & sounds like a head gasket problem now. But try the thermostat before you get into any major repairs.
2000 Esteem. J20 (2.0) swap. T3 turbo - 7psi boost, exhaust, Clutchmasters stage 4 clutch. drag; 14.5sec @97.3mph in 1/4 mile. More changes to come.
wildebeast
Aerio Veteran
Aerio Veteran
 
Posts: 948
Joined: Sat Apr 29, 2006 9:01 pm
Location: Florida. USA


Return to Video Vault

Who is online

Users browsing this forum: Google [Bot] and 2 guests

  • Advertisement